[2018-01-05] How to fix an expired gpg key to be able to run a system update on arch linux again

When I run my first update in the new year, I had the problem that one of the gpg keys expired, and I couldn't update my system.

$ sudo pacman -Syyu
error: pkgbuilder: signature from "Chris Warrick <kwpolska@gmail.com>" is unknown trust
:: Synchronizing package databases...
 core                                                                                                 126.8 KiB  1527K/s 00:00 [#############################################################################] 100%
 extra                                                                                               1639.8 KiB  10.0M/s 00:00 [#############################################################################] 100%
 community                                                                                              4.3 MiB  18.0M/s 00:00 [#############################################################################] 100%
 multilib                                                                                             168.6 KiB  23.5M/s 00:00 [#############################################################################] 100%
 pkgbuilder                                                                                           846.0   B  0.00B/s 00:00 [#############################################################################] 100%
 pkgbuilder.sig                                                                                       310.0   B  0.00B/s 00:00 [#############################################################################] 100%
error: pkgbuilder: signature from "Chris Warrick <kwpolska@gmail.com>" is unknown trust
error: failed to update pkgbuilder (invalid or corrupted database (PGP signature))
 sublime-text                                                                                        1080.0   B  0.00B/s 00:00 [#############################################################################] 100%
 sublime-text.sig                                                                                     543.0   B  0.00B/s 00:00 [#############################################################################] 100%
error: database 'pkgbuilder' is not valid (invalid or corrupted database (PGP signature))

The solution was to refresh all keys with

$ sudo pacman-key --refresh-keys